Troop Management Software and Web Hosting for Scouts BSA User Guide
 
search 
 

Is your system ScoutNet™ certified?

No, but it is not for lack of effort or willingness on our part. The BSA™ has informed us that they no longer offer certification to new software packages. It appears that they have not allowed any new software vendors to be certified for at least ten years.

As a result, one thing that ScoutNet™ certification tells you is that the certified software is based on outdated technology, since it had to have been created over a decade ago.

However, since the ScoutNet™ advancement file is a simple CSV file, it was relatively easy for us to determine the format of the file and create a compatible output file.

We are confident that you can use this file to submit your advancement data.


Why are the requirements for some ranks different for my older scouts?

From time to time, the BSA™ changes the requirements for some or all of the scout ranks.  Since we began TroopWebHost we've seen two major sets of changes, in 2010 and 2016.  The changes which took effect on January 1, 2016, affected all ranks from Boy Scout to Eagle.

Scouts who had already earned some requirements using the earlier version will be grandfathered in with the old set of requirements.

The system will default to the newest version of the rank requirements for scouts who have not completed any requirements for that rank.


I have a scout who is using the older version of the requirements for First Class, but the system is showing the 2016 requirements.  How can I fix this?

We added the 2016 rank requirements to TroopWebHost in December of 2015.

After that date, scouts who had not yet earned any requirements for a rank were set to use the 2016 requirements.   Scouts who had already completed at least one requirement using the old rank requirements will stay with the old requirements for that rank.

If you are seeing the 2016 requirements for a scout who is using the earlier requirements, you can change him to the previous requirements using the drop down list you'll see in the lower right corner of every rank page, as shown below.

The dropdown list will only work if the scout has NO requirements marked as complete for this rank.



To change a scout to a different version of the requirements for a given rank:
  1. Clear all checkmarks from all requirements for this rank.
  2. Click the Save button.
  3. Select a different Requirements Version from the drop down list.
  4. Click the Save button again.
  5. You should now see the requirements for the version you selected.
  6. Check off the requirements that this scout has completed so far.
  7. Click the Save button one more time.